Ticketdaten fehlen in Leistungsdetails

Hauptartikel:
Fehlermeldungen

 

Fehlerbeschreibung

Bei einer Flugbuchung sollen Ticketdaten eingetragen werden. Die entsprechende Schaltfläche in den Leistungsdetails fehlt jedoch. 

Ursache

Die Konfiguration der Unit ist unvollständig oder fehlerhaft. 

Lösung

Damit die Eingabe möglich ist, muss folgende Konfiguration vorhanden sein:

  1. In der agency Tabelle gibt es für jede Agentur eine reservationTypeConfigGroup (kann auch für jede Agentur die gleiche Gruppe sein)

  2. Für jede dieser reservationTypeConfigGroup kann in der Tabelle reservationtypeconfiguration pro Leistungsart (Pauschal, Flug, Hotel, usw) ein Eintrag gemacht werden

  3. Für jeden dieser Einträge kann dann in der Tabelle reservationtypeconfiguration_defaultdetails festgelegt werden, welche Leistungsdetails auswählbar sind, also welche Leistungsdetail-Buttons sichtbar sind.

Die Entwicklung kann prüfen, ob die Konfiguration für die Eingabe der Ticketdetails korrekt ist.